0 votes
asked in Bug Report by
I Just installed uMotion community for Unity 2018.3.0f2. it keeps giving me these 2 error messages

 Assembly 'Assets/Editor Default Resources/UMotionEditor/Plugins/Application/UMotionApplication.dll' will not be loaded due to errors:

Unable to resolve reference 'Assembly-CSharp'. Is the assembly missing or incompatible with the current platform?

and secondly

Assembly 'Assets/Editor Default Resources/UMotionEditor/Plugins/Editor/UMotionEditor.dll' will not be loaded due to errors:

Unable to resolve reference 'Assembly-CSharp'. Is the assembly missing or incompatible with the current platform?

Unable to resolve reference 'Assembly-CSharp-Editor'. Is the assembly missing or incompatible with the current platform?

please help

1 Answer

0 votes
answered by Expert (155k points)
selected by
 
Best answer
Hi bob,
thank you very much for the bug report.

These error messages are false alerts generated by Unity when importing UMotion into a project. I've already been in contact with Unity and unfortunately there isn't much I can do against these. Anyway, the functionality of UMotion should not be affected (you should still be able to open UMotion's Clip Editor via "Window / UMotion Editor / Clip Editor"). Please let me know if this is not the case and you've detected a functional defect.

Best regards,
Peter
commented by
I get the same errors.  I can not load Kyle or any other model into the Pose Editor.  I just purchased Umotion and am trying to test it out.  Unity 2018.3.Of2 is very different from the version that I had been using so I am at a total loss as to what is happening and how to deal with it.
commented by Expert (155k points)

Hi Susan,
thank you very much for reaching out.

As mentioned, this error is a false alert generated when Unity imports UMotion. Sadly there isn't much I can do against this issue as it is generated before any code of UMotion is executed. Anyway it should not influence the functionality of UMotion.

I can not load Kyle or any other model into the Pose Editor.

What happens when you try to load Kyle into the Pose Editor? If you are using HD Render Pipeline, it might be this problem that you are facing: https://support.soxware.com/1618/white-screen-when-loading-avatar

The upcoming patch (currently under review by the Asset Store) is going to fix this HDRP related problem.

I'm sorry for the issues. Please let me know if you are able to resolve it.

Best regards,
Peter

commented by
I just purchased UMPro and I'm getting the same errors and I'm unable to drag and drop any game objects into the pose editor. I'm also unable to select any avatar/game object from within the pose editor.

I've tried the standard pipeline and HDRP, it doesn't work with either. I have a deadline and I was hoping UMotion would speed up the process.

Is there a fix for this? This asset is unable to do anything at all in my projects.

ETA: I'm using v 2018.3
commented by Expert (155k points)

Hi Mill,
thank you very much for reaching out.

I'm unable to drag and drop any game objects into the pose editor.

I assume that the UMotion windows show up for you, so you can safely ignore the error message (it's just a false alert generated by the package importing process). Please make sure that you've created a new UMotion Project before you drag & drop your character into the Pose Editor.

Please follow this quick start video tutorial: Quick Start - UMotion Official Tutorials

HDRP and standard pipeline as well as Unity 2018.3 are tested and should work. If something is not working as described in the video tutorial above, please let me know and I'm going to make sure to help you out.

Best regards,
Peter

commented by
Hi Peter,

Thanks for the suggestion, I actually did watch the tutorial before commenting here but after your post I went back and watched again and realized-- I missed a step! You were also right that it had nothing to do with the false error messages.

I'm living on coffee and energy drinks so I must have missed it the first time I watched. I'm so grateful that you responded as quickly as you did. Thank you!

All the best to you.
commented by Expert (155k points)
Hi Mill,
glad to hear that everything is now working as expected. Don't hesitate to contact me in the future if you have any questions.

Best regards,
Peter

Soxware Support

Here you get official product support by the developer and the community for all Soxware Products for Unity®.

Post as guest, login via Facebook or create an account.

Ask questions, report bugs or provide feedback. Please use the correct category and always post in english.

For private email support, please use the Support Form to create a support ticket.

Copyright © 2017 Soxware Interactive | All Rights Reserved | Impressum

...