0 votes
asked in Bug Report by

Hi there, 
I've got Umotion pro and after installing Unity 2018.3 I cannot get the "clip editor" to show anymore. 
When I try to open it, the window shows empty and then crashes (disappears) after a few seconds. Errors below:

- GUI Window tried to begin rendering while something else had not finished rendering! Either you have a recursive OnGUI rendering, or the previous OnGUI did not clean up properly.
- ArgumentException: Getting control 1's position in a group with only 1 controls when doing repaint Aborting
- Assertion failed on expression: 'device.IsInsideFrame()'


I tried uninstalling and then reinstalling several times but it didn't fix the problem.

Any ideas?
Thanks in advance

1 Answer

0 votes
answered by Expert (133k points)
selected by
 
Best answer

Hi,
thank you very much for your bug report.

I've tried to reproduce this: I've created a new Untiy Project in 2018.3.0f2 and installed the latest UMotion version from the Asset Store (V1.15p03). I've used a Windows 10 PC. I was able to open the Clip Editor without getting error messages.

  1. Which operating system are you using?
  2. Does the problem appear for you when you create an empty Unity project like I did, or does it only appear in your project?
Best regards,
Peter
commented by

Hi, I am using windows 10 x64 and the latest UMotionPro from asset store. I am also using runtime 4.x (Player settings).

I just created a new project and reimported UMotion and the original error reported above is not showing, but I get the error below:

Assembly 'Assets/Editor Default Resources/UMotionEditor/Plugins/Application/UMotionApplication.dll' will not be loaded due to errors: Unable to resolve reference 'Assembly-CSharp'. Is the assembly missing or incompatible with the current platform?

Regardless of the error, the window at least is showing properly, so I guess there's a conflict in my main project?

I reckon this might be an unity bug but if you know what is the root cause I would appreciate.

Thanks

commented by Expert (133k points)

Ok, thanks for the additional information. 

Assembly 'Assets/Editor Default Resources/UMotionEditor/Plugins/Application/UMotionApplication.dll' will not be loaded due to errors: Unable to resolve reference 'Assembly-CSharp'. Is the assembly missing or incompatible with the current platform?

That error appears from time to time when installing UMotion for the first time. It's more of a false alert that appears when the package importer wants to load the UMotion *.dlls but hasn't compiled the source files yet. As soon as Unity finished compiling, everything is working as expected so you can savely ignore this message.

 so I guess there's a conflict in my main project?

Yes that's most probably the case. I think this would be the easiest way to trace down the root cause of this issue:

  1. Duplicate your whole Unity project folder (of your main project).
  2. Open the duplicated project in Unity.
  3. Start to delete editor extensions one after another. Try to open the UMotion Clip Editor after every deleted editor extension.

The last editor extension that you've deleted before you are able to open the Clip Editor is likely causing the conflict. Maybe it's also a package that you've installed via Unity's Package Manager.

Please let me know what package is causing the issue and I will see what I can do to avoid this in the future.

Best regards,
Peter

Soxware Support

Here you get official product support by the developer and the community for all Soxware Products for Unity®.

Post as guest, login via Facebook or create an account.

Ask questions, report bugs or provide feedback. Please use the correct category and always post in english.

For private email support, please use the Support Form to create a support ticket.

Copyright © 2017 Soxware Interactive | All Rights Reserved | Impressum

...