0 votes
asked in General Help by
Hi!

When converting an animation from Generic to Humanoid using the MCS Female model, the Humanoid animations turn up empty. No curves anything else on the Animator window is shown, aside from the bones. In the original Generic animation, the curves are visible.

What am I doing wrong? Could it be that when creating the Generic reference model, I use the wrong root-bones? I have tried both the main GameObject and hips, since this model does not list a root. What else can I try?

Best,
Maarten

1 Answer

0 votes
answered by Expert (111k points)
 
Best answer

Hi Maarten,
thank you very much for your support request.

Are the 2 models that you provide via the UI window exactly the same models (except that one is configured as humanoid and the other as generic)?

Is the humanoid avatar of the humanoid model configured correctly (there must be a white check mark in the "Rig" tab in the Inspector next to the "Configure..." button)? Please also validate if other humanoid animations play correctly on that model.

If that doesn't help, please send me a Unity project that includes everything I need to reproduce your situation on my PC (please remove anything not related to this problem) via the email support form.

Best regards,
Peter

commented by
Hi Peter, thanks for your speedy reply!

Thank you for the tips, this helped me get the converter to work!!

I started a fresh project and built from scratch, because I had been messing so much with the avatars that I didn't know which was the right one. In the new project the conversion seems to work often enough.

One thing I did notice is that sometimes the conversion freezes the computer for a long time on the 'conversion complete' popup window, while at other times it is really fast. This is even the case when converting the exact same animation twice in a row. Is there something I can do to fix this?

Later today I will try if the recording/conversion works with the Vive trackers and ManusVR gloves, which is the entire point of my work :).

Thanks again!

Maarten
commented by Expert (111k points)

Hi Maarten,
great to here that everything is now working as expected. 

This is even the case when converting the exact same animation twice in a row. Is there something I can do to fix this?

I also noticed this from time to time, but I'm afraid that this is Unity reloading from the file system so there isn't much I can do to avoid this.

Later today I will try if the recording/conversion works with the Vive trackers and ManusVR gloves, which is the entire point of my work :). 

 Sounds great, would love to see the result :-)

Best regards,
Peter

Soxware Support

Here you get official product support by the developer and the community for all Soxware Products for Unity®.

Post as guest, login via Facebook or create an account.

Ask questions, report bugs or provide feedback. Please use the correct category and always post in english.

For private email support, please use the Support Form to create a support ticket.

Copyright © 2017 Soxware Interactive | All Rights Reserved | Impressum

...